• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Tried ART instead of Dalvik on Nexus 4, Battery drained to zero

Avinash

Administrator
Staff member
#1
I just tried to use the new ART runtime on my Nexus 4 witch Stock Android 4.4 by enabling it under developer options. It needed a reboot. Before reboot happened, the battery level on Nexus 5 was ~44%.

But when reboot finished with the upgrading apps message on screen, the battery died to zero and phone was shut down. I had to use the charger again to boot it.

So what the battery drain to zero means for Nexus 4 with ART runtime? Has anyone else experienced it? or we cannot use ART on Nexus 4?

Atm, I reverted back to Dalvik again.
 
#2
That is unusually weird for the battery level to drop like that. Just out of curiosity, how long did it take for the phone to reboot?

Maybe because it was rebuilding the cache, it took a big chunk of the battery.
 

Avinash

Administrator
Staff member
#3
I thought the same.

Reboot doesnt take too much time, just few 1-2 minutes extra perhaps while it was showing message of upgrading apps (almost 138 apps it showed).
 

Avinash

Administrator
Staff member
#4
Just found something else. It looks as if enabling ART messed up the Recovery. When i tried rebooting to recovery, i was greeted with the triangular button and no recovery.
 
#5
Looks like this may be a big issue. I recommend taking a backup of your apps and reflashing the factory image from this link. https://developers.google.com/android/nexus/images